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1.1 Basic installation 
After you have inserted the KISSsoft CD in the appropriate disk drive, the setup 

program starts automatically. If it does not, you can run the setup.exe file directly 

in the CD root directory by double-clicking on it. 

The setup program guides you through the installation process step by step. All you 

need to do is select an installation folder and the required language for the installa-

tion. If you change the default installation folder, it is advisable to include the ver-

sion descriptor as part of the directory name of the other installation folder (e.g. 

C:/Programs/KISSsoft xx-20xx). 

At the end of the installation we recommend that you install the latest Service Pack 

(patch). Download the latest patch http://www.kisssoft.ch/patches.php from our 

website. You can choose between an installation program (*.exe) and zipped files 

(*.zip). The installation program automatically copies the necessary files after you 

specify which installation folder it is to use. However, not all companies permit exe 

files to be downloaded. In this case, you must unpack the ZIP file and manually 

copy the files it contains into your installation folder. Any files that are already 

present must be overwritten by the ones contained in the patch. 

After you have installed KISSsoft you need to license (see page  I-44) it. If KISS-

soft is not licensed, it will only run as a demo. 

If you are installing KISSsoft on a server, we recommend that you perform the in-

stallation from a client (workstation computer). Consequently, all necessary direc-

tory entries will automatically be added to the KISS.ini (see page  I-53) file 

correctly. Otherwise, you will have to change these directory entries from the local 

drive name (e.g. C:/...) to the appropriate share name in the network, later, 

manually, using an editor. 
 

NOTE: 

http://www.kisssoft.ch/patches.php
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1.2 Downloading a license file 
1. Go to our website, www.KISSsoft.ch, and click on the Service/Support pa-

ge link on the left. There, you will find a link to the "customer zone". Click 

on the link. You will see the Customer Zone web page. In that page, on the 

top right-hand side, enter your license number in the License Number field, 

and click on "Open".  

2. A login window will open, in which you enter your license number, and al-

so your download password, again. If you do not have this password, plea-

se get in touch with your commercial contact representative or contact di-

rectly KISSsoft via e-mail on info@KISSsoft.CH or phone number +41 55 

254 20 53. 

3. You are now in your personal download area. Save the lizenzxxxx.lic file 

in the license directory of your KISSsoft installation. 

 

It may be that your personal download area contains license files for different ver-

sions of KISSsoft. Please make sure you select the correct license file for the sys-

tem version you have just installed. 
 

NOTE: 
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1.3 Licensing 
After you have performed the KISSsoft Installation (see page  I-42), you must li-

cense the software either by downloading a license file or activating the program's 

license. Please read the relevant section for your type of license. 
 

1.3.1 Test version 
1. If you start KISSsoft from the client (workstation computer), the user ac-

count for the test version will become active. 

2. Open the License tool  in the Extras  menu and then click on the Ac-

tivate license tab. 

3. Activate online: If your computer has Internet access, and you have recei-

ved an online code from us, enter this code under the Release Test 

or Student version  option and then click on Activate lice n-

se . 

4. Direct activation:  Under the Activate test version by phone  

option you see find a question code. Call the telephone number you see the-

re and tell us this code. We will then give you the appropriate answer code. 

Input this in the corresponding field and click the Activate l i cense 

tab . 
 

1.3.2 Student version 
1. Copy your license file (you will usually be given this by your high school) 

to your License directory (see page  I-54). 

2. Open the License tool  in the Extras  menu and then click the Acti-

vate license tab. 

3. Input your online code (which you will also be given by your high school) 

under the Activate test or student version  option and click 

on Activate license tab . 
 

1.3.3 Single user version with dongle 
1. Copy your license file (see page  I-43) to your license directory (see page  

I-54). 

2. Now, simply plug in the dongle supplied with the system. 

NOTE 
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The single user version of KISSsoft can also be installed on a central server. Local 

clients (workstation computers) can then run the software directly from this server. 

Please note here that the dongle must always be plugged into each particular client. 
 

1.3.4 Single user version with l icense code 
1. Start KISSsoft from the client (workstation computer) for which the soft-

ware is to be licensed. 

2. Select License tool  in the Extras  menu and click on the Activate li-

cense tab. 

3. Enter your contact data under the Request license file  option and 

click on Send to send your computer-specific access data directly to us. 

Al ternatively, you can first save this access data in a file and then send us 

this file by email. 

4. You will receive an email as soon as we have created your license file. 

5. Download your License file (see page  I-43) and copy it to your License di-

rectory (see page  I-54). 
 

1.3.5 Network version with dongle 
For the network version with dongle a server program has to be installed in additi-

on to the licensing of the KISSsoft installation. 
 

1.3.5.1 Instal lat ion on the server 

1. Copy the KISSsoft dongle/MxNet installation directory onto a server. 

2. Start MxNet32 on the server. You will see a dongle icon in the task bar. 

3. Double-click this icon to start the user interface. 

4. Now enter Application : KISSsoft and any file with the file extension 

*.mx as the server file . The clients must have both read and write ac-

cess to this file. Now click New Entry  to add this entry. 

5. Then click the Active Users  button to check who is using KISSsoft. 

You can also reactivate a license that has already been used. 
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1.3.5.2 Licensing the KISSsoft system. 

1. Copy your license file (see page  I-43) to your license directory (see page  

I-54). 

2. Complete the necessary details in the "ServerFile: serverfilepath" line after 

the checksum line in the license file. The "serverfilepath" is the path to the 

server file that is defined in the server program. 

The KISSsoft installation will also run if the client is not connected to the network 

and if the dongle is inserted in the client instead of in the server. You can also 

"check out" the license if you remove the dongle. 
 

1.3.6 Network version with the license code 
1. Start KISSsoft from a client (workstation computer). 

2. Select License tool  in the Extras  menu and go to the General tab. 

3. Select an access directory on a server. Please note: If you change this, you 

will need a new license. 

4. Go to the Activate license tab. 

5. Enter your contact data under the Request license file  option and 

click on Send to send your computer-specific access data directly to us. 

Alternatively, you can first save this access data in a file and then send us 

this file by email. 

6. You will receive an email as soon as we have created your license file. 

7. Download your License file (see page  I-43) and copy it to your License di-

rectory (see page  I-53). 

 

NOTE 
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2 Setting Up KISSsoft 

Chapter 2 

Setting Up KISSsoft 
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2.1 Directory structure 
If there are several users it is advisable to store shared data (databases, user-

defined report templates and standard files) on one server. This ensures that, if 

there are changes and upgrades, all users will be able to work with one uniform set 

of data. To set this up, move the KDB, EXT and TEMPLATE directories onto a 

server that can be accessed by all users, and then tailor the corresponding variables, 

KDBDIR, EXTDIR and TEMPLATEDIR, in the KISS.ini (see page  I-53) file. 

In contrast, the temporary directories should be defined locally on the workstations 

for several users. Otherwise, the interim results of individual users might overwrite 

each other. For each installation, KISSsoft uses the temporary user directory in 

accordance with the operating system. The CADDIR and TEMPDIR variables can, 

however, be tailored in the KISS.ini (see page  I-53) file. 

If you want to open or save a calculation file or a report, KISSsoft offers you your 

personal User directory as the first choice storage location. This saves you 

frequent searches in the directories on your system. You can define this user direc-

tory via the USERDIR variable in the KISS.ini (see page  I-53) file. The user direc-

tory will be ignored if you have selected an active working project (see page  I-90). 

In this case, KISSsoft offers you the project directory as the first choice storage 

location. 
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2.2 Language settings 
KISSsoft is available in five languages: English, French, German, Italian and 

Spanish. When you select a language, the program differentiates between the lan-

guage used for the user interface and the language used for the reports. It is 

therefore possible to operate KISSsoft in one language and to simultaneously dis-

play reports in a different language. Messages will be displayed either in the same 

language as the user interface or as the reports. 

For global language settings, you need to edit the KISS.ini file (see page  I-54). 

Additionally, you can also quickly toggle between languages in the program by 

selecting Extras > Language , and then the required language. The user can 

change the language used for reports by selecting Report >   Settings , and 

then the required language (from the drop-down menu). 
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2.3 System of units 
KISSsoft recognizes two unit systems: the metric system and the US Customary 

Units system. For global language settings, you need to edit the KISS.ini file (see 

page  I-54). You can also quickly toggle between systems of units in the program 

by selecting Extras > System of units . In addition to changing the sys-

tem of units, it is  possible to switch the unit used for a particular value input field 

(see page  I-83). 
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2.4 Defining your own default files 
Anyone who frequently carries out the same, or at least similar, calculations has to 

repeatedly enter the same values into selection lists and value input fields. Thanks 

to default files, KISSsoft makes your work considerably easier here. For each 

calculation module, there is an internal default setting for all values.  If, however, 

you have defined your own default file, this default file will be used when you open 

a calculation module or load a new file. 

To define a default file, you open a new file in the corresponding calculation modu-

le and enter your default settings.  To transfer your values into the default file, se-

lect File >  Save as template .  All template files will be saved in the di-

rectory that has been defined as TEMPLATEDIR (see page  I-53). 

Default files can also be defined as project-specific.  To define special standards for 

a project (see page  I-87), select this project in the project tree (see page  I-69) and 

open its properties by selecting Project > Properties . There, select Use 

own templates for this project  and specify a directory for the default 

files.  To define the default files you must select this project as the Active working 

project (see page  I-90). 
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2.5 Rights 
You can restrict the rights for selected areas of KISSsoft for some users. 

 

Right Implementation 

Changes to the general settings Write protect the KISS.ini (see page  I-53) file 

Changes or additions in the databases Write protect databases (files of the type *.kdb) as well as 

the directories DAT and EXT/DAT (but write rights for 

KDBDIR (see page  I-53) should be retained) 

Changes to the report templates Write protect RPT, EXT/RPT and EXT/RPU directories 

Changes to the template files Write protect the TEMPLATE directory 
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2.6 Global settings - KISS.ini 
Global settings for KISSsoft are defined in the KISS.ini file, which is located 

directly in the installation folder. 
 

2.6.1 Definitions in [PATH] 
 

Variable name Description Note 

KISSDIR=<INID

IR>  

The KISSsoft installation folder is 

generally defined with the 

INIDIR  variable. 

 

HELPDIR Directory for user manual and help 

figures 

 

DATADIR Directory for files of the type *.dat Warning:  You should not carry out any up-

grades or make any changes in this directory. 

Save your own files in the DAT subdirectory 

in the EXTDIR. 

RPTDIR Directory for report templates 

(*.rpt) 

Warning:  You should not carry out any up-

grades or make any changes in this directory. 

Save your own files in the RPT subdirectory in 

the EXTDIR. 

USERDIR Default directory for opening and 

saving 

 

CADDIR  Default directory for CAD export Should be located locally on a workstation 

%TEMP% sets the temporary directory to suit 

a particular operating system 

TMPDIR  Directory for temporary files Should be located locally on a workstation 

%TEMP% sets the temporary directory to suit 

a particular operating system 

KDBDIR Directory for KISSsoft's databases 

(*.kdb) 

If several users are using the system, we 

recommend you store the databases on one 

server to ensure a uniform standard if there are 

changes and upgrades. 

EXTDIR Directory for user-defined report 

templates and additional DAT files 

If there are several users, it is advisable to 

store this directory on one server. 

TEMPLATEDIR Directory for template files 

(STANDARD.*). 

If there are several users, it is advisable to 

store this directory on one server. 

LICDIR  Directory for the license files You can install this directory on a server so 

that all the users can access the new license 

files. 

Table 2.1: Table containing the variables used in the environment PATH 
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You should have write permission for the directories set in TMPDIR, CADDIR and 

USRDIR, as well as for the directory set in KDBDIR. 

Depending on the configuration, you may not have write permission in Windows 

VISTA in the directory C: \ Program Files \ <KISSsoft Directory  Name>. 

Written files will then be diverted to internal VISTA directories. Here, please select 

directories with write permission. 
 

2.6.2 Definitions in [SETUP] 
  

Variable name Explanation  Values 

USCUSTOMARYUNITS Sets the system of units 0: metric, 1: i m-

perial  

REPORTLANGUAGE Sets the language in which 

reports are displayed 
0: German, 1: English, 2: 

French,3: Italian,4: Spanish, 

11 : English with US 

Customary Units 

DISPLAYLANGUAGE Sets the language in which the 

user interface is displayed 
0: German, 1: English, 2: 

French,3: Italian, 4: Spanish 

MESSAGESINREPORTLANGUAG

E 

Sets the language in which 

messages are displayed 
0: like interface, 

1: like reports  

MESSAGESSHOWSTATE Defines which messages are to 

appear as a message box. 
0: all, 1: information only in 

the message window, 2: in-

formation and warnings only in 

the message window 

EDITOR Path to the external editor  

USEEXTERNALEDITOR Defines whether the external 

editor is to be used. 
0: No, 1: Yes 

DATEFORMAT Date format, e.g. dd.mm.yyyy  

TIMEFORMAT Time format, e.g. hh.mm.ss  

ENABLENETWORKING Defines whether the net-

work/Internet may be accessed 

(for example, to display inno-

vations). 

0: No, 1: Yes 

CHECKFORUPDATES Defines whether the system is 

to search for updates when the 

program starts. 

0: No, 1: Yes 

USETEMPORARYDATABASE Defines whether the databases 

are to be copied to a temporary 

directory when the program 

0: No, 1: Yes 

NOTE 
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starts 

RECENTFILESCOUNT Number of most recently used 

files in the File menu 

 

Table 2.2: Table showing which variables are used in the SETUP environment  

 

2.6.3 Definitions in [REPORT] 
  

Variable name Description  

SIZE  Number 0÷9 that specifies the scope of the report 

INCLUDEWARNINGS 0/1: Warnings are contained in the report 

FONTSIZE Number for the font size in the report 

PAPERFORMAT Paper format: A3, A4, A5, Letter, Legal 

PAPERORIENTATION 0/1: Portrait/Landscape 

PAPERMARGINLEFT Distance from the left-hand page margin [mm] 

PAPERMARGINRIGHT Distance from the right-hand page margin [mm] 

PAPERMARGINTOP Distance from the top page margin [mm] 

PAPERMARGINBOTTOM Distance from the bottom page margin [mm] 

COMPARE 0/1: Adds date/time to the report in comparison mode 

SAVEFORMAT 0 ÷3: RTF, PDF, DOC, TXT 

LOGO Graphic file displayed in the header and footer 

HEADER Definition of the header 

USEHEADERFORALLPAGES 0/1: header only on first page/on all pages 

FOOTER Definition of the footer 

USEFOOTERFORALLPAGES 0/1: Footer only on first page/on all pages 

Table 2.3: Table containing the variables used in the environment REPORT 

 

2.6.4 Definitions in [GRAPHICS] 
  

Variable name Explanation  

BACKGROUND 0: black, 15 : white (for more information, see Graphics > 

Settings ) 

Table 2.3b: Table showing which variables are used in the GRAPHICS environment  
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2.6.5 Definitionen in [LICENSE] 
  

Variable name Description 

LOGGING  Number to activate the logging of license usage 

0: no logfile 

1: Login, Logout, no license, used and missing permissions 

2: Login, Logout, no license 

3: Login, Logout, no license, missing permissions 

LICENSELOGFILE *.log  file for generating reports of license usage 

TIMEOUT Duration until an unused floating license will be activated on the network 

again [min]  

Table 2.4: Table containing the variables used in the LICENSE environment 

 

2.6.6 Definitions in [CADEXPORT] 
 

Variable name Description 

USEDXFHEADER 0/1: DXF header will be used for DXF export 

DXFVERSION 0/1: Version 12/15  

INPUTLAYER Name of the layer for import  

OUTPUTLAYER Name of the layer for export  

DXFPOLYLINE 0/1/2: Uses polygonal course, lines or points for the export 

Table 2.5: Table containing the variables used in the CADEXPORT environment  

 

2.6.7 Definitions in [INTERFACES] 
  

Variable name Description 

DEFAULT  Name of the CAD system: 

 PartGear 

 SolidEdge 

 SolidWorks 

 Inventor 
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 CATIA  

 ProEngineer 

 CoCreate 

 Think3 

 HiCAD 

GEAREXPORT3D Displays the CAD system name in lists (see DEFAULT)  

SYMMETRIC 0/1: Full tooth space/ Half tooth space mirrored (symmetric) 

(Default = 0) 

SAVEFILENAME 0/1: Save the whole contents of the file/ Save only the file name with path 

(Default = 1) 

Table 2.6: Table containing the variables used in the INTERFACES environment 

 

2.6.8 Definitions in [PARTGEAR] 
  

Variable name Description 

COMMAND  PartGear directory (pgear.exe ) 

FACTOR_A  Sets the accuracy for 3D generation 

FACTOR_B Number of sections  

FACTOR_C Number of sections per 360
o
 coil  

Table 2.7: Table containing the variables used in the PARTGEAR environment 

 

2.6.9 Definitions in [SOLIDEDGE] 
  

Variable name Description  

LIBRARY Interface dll (kSoftSolidEdge.dll ) directory  

SMARTPATTERN 0/1: Fastpattern/Smartpattern  

APPROXIMATION 1/2/3: polygonal course (supported)/arcs (supported)/splines (standard)  

Table 2.8: Table containing the variables used in the SOLIDEDGE environment 

 

2.6.10 Definitions in [SOLIDWORKS] 
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Variable name Description  

LIBRARY Interface dll (kSoftSolidWorks.dll ) directory  

SIMPLIFIEDPRESENTATIONN

AME 

Setting this variable generates a simplified gear with this name 

APPROXIMATION  1/2/3: polygonal course (supported)/arcs (supported)/splines (stan-

dard)  

Table 2.9: Table containing the variables used in the SOLIDWORKS environment 

 

2.6.11 Definitions in [INVENTOR] 
  

Variable name Description  

LIBRARY Interface dll (kSoftInventor.dll ) directory  

APPROXIMATION 1/2/3: polygonal course (supported)/arcs (standard)/splines (not 

supported)  

Table 2.10: Table containing the variables used in the INVENTOR environment 

 

2.6.12 Definitions in [CATIA] 
  

Variable name Description  

LIBRARY Interface dll (kSoftCatia.dll ) directory  

LIBRARYSWMS Interface manufacturer's *.dll  file directory  

LANGUAGEFILE Interface manufacturer's *.dll  file directory  

DEBUG Interface manufacturer's variable  

DEBUGPATH Interface manufacturer's variable  

HELPFILE  Interface manufacturer's variable  

LASTSET-

TING_CONSTRUCTION 

Interface manufacturer's variable  

LASTSETTING_GEARNAME Interface manufacturer's variable  

LASTSET-

TING_PRODUCTIONINFO 

Interface manufacturer's variable  

LASTSETTING_CALCINFO  Interface manufacturer's variable  

LASTSETTING_FLAGINFO  Interface manufacturer's variable  
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APPROXIMATION  1/2/3: polygonal course (not supported)/arcs (standard)/splines 

(not supported)  

Table 2.11: Table containing the variables used in the CATIA environment 

 

2.6.13 Definitions in [PROENGINEER] 
The ProEngineer interface has an individual subsection/menu for each version (for 

example, Wildfire 3, 32bit), 

however the definitions in "kiss.ini" are the same in every ProEngineer chapter. 
 
 
 

Variable name Explanation  

LIBRARY Interface dll (kSoftProEngineer.dll ) directory  

INTERFACECOMMAND Directory of the *.exe  files of the interface manufacturer 

USCUSTOMARYUNITS 0/1: System of units of the metric/US Customary Units model 

APPROXIMATION  1/2/3: polygonal course (not supported)/arcs (standard)/splines (not 

supported)  

Table 2.12: Table showing which variables are used in the PROENGINEER enviro n-

ment  

 

2.6.14 Definitions in [SOLIDDESIGNER] 
  

Variable name Description  

LIBRARY Interface dll (kSoftCoCreate.dll ) directory  

INTERFACECOMMAN

D 

Interface manufacturer's *.exe  file directory 

APPROXIMATION  1/2/3: polygonal course (not supported)/arcs (not supported)/splines (standard)  

Table 2.13: Table containing the variables used in the COCREATE environment 

 
 

2.6.15 Definitions in [THINK3] 
  

Variable name Description  

LIBRARY Directory of the interface dll (kSoftThin k3.dll )  
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INTERFACECOMMAN

D 

Interface manufacturer's *.exe  file directory   

APPROXIMATION  1/2/3: polygonal course (not supported)/arcs (standard)/splines (not supported)  

Table 2.14: Table containing the variables used in the environment THINK3 

 

2.6.16 Definition in [HICAD] 
 

Variable name Description  

LIBRARY Directory in the interface dll (kSoftHiCAD.dll )  

APPROXIMATION  1/2/3: polygonal course (not supported)/arcs (standard)/splines (not supported)  

Table 2.15: Table containing the variables used in the environment HICAD 
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2.7 User-defined settings 

2.7.1 Configuration tool 
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Chapter 3 
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3.1 Initial parameters 
KISSsoft can be called up from the input prompt with the following initial parame-

ters: 
 

Parameter Description  

INI=directory  The KISS.ini (see page  I-53) file will be loaded from the specified locati-

on. You can transfer a file name including its directory path, or only a di-

rectory name.  

START=module  The specified calculation module will be started. The module descriptor is, 

for example, M040 for bolt calculation or Z012   for cylindrical gear pair 

calculation.  

LOAD=file name  The calculation module belonging to the file is started and the file is 

loaded. If the supplied file name does not include a path, the system looks 

for the file in the User directory (see page  I-53). 

LANGUAGE=number  KISSsoft starts with the language specified for the interface and reports. (0: 

German, 1: English, 2: French, 3: Italian, 4: Spanish, 11: English with US 

Customary Units) 

DEBUG=filename  A log file with debug information will be written which can be very helpful 

for error-tracking. It is advisable to define the file name with a complete 

path, so that you can find the log file easily later. 

File name  The calculation module belonging to the file is started and the file is 

loaded. This also provides a way to associate KISSsoft with the appropriate 

filename extensions in Windows. 
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3.2 Disconnect license from the network 
If KISSsoft has not been properly shut down, it may be possible that users remain 

registered, in the case of a network version. This may lead to licenses being 

blocked even though some users are no longer working with KISSsoft. You can 

disconnect a license from the network by selecting the required license (the user 

and start time are also specified) under Extras > License tool  in the Net-

work  tab, which deletes the appropriate cookie file and activates the blocked licen-

se on the network again. 

Unused licenses will be activated  after a certain time, as soon as the next user logs 

on. This time-span can be predefined via the TIMEOUT (see page  I-56) variable in 

the KISS.ini (see page  I-53) file. 

A user who has been disconnected from KISSsoft can no longer carry out 

calculations in the current session. The user must restart KISSsoft. However, data 

backups can still be carried out. 

 

NOTE 
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4 Elements o f the KISSsoft Us er Interface 

Chapter 4 

User Interface 
KISSsoft is a Windows-compliant software application. Regular Windows users 

will recognize the elements of the user interface, such as the menus and context 

menus, docking window, dialogs, Tooltips and Status bar, from other applications. 

Because the internationally valid Windows Style Guides are applied during deve-

lopment, Windows users will quickly become familiar with how to use KISSsoft. 

 

Figure 4.1: KISSsoft's user interface 
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4.1 Menus, context menus and the Tool Bar 
In the File main menu you can open, store, and send calculation files as e-mail 

attachments, restore previous calculation stages, view file properties and close 

KISSsoft. Click File > Save as template  to retain user-defined default 

values (standard files (see page  I-51)). 

You can use the KISSsoft Project Management (see page  I-87) functionality from 

both the Project main menu and the Project tree (see page  I-69). You can open, 

close and activate projects, insert files into a project, or delete them, and also view 

project properties. 

Each individual Docking window (see page  I-68) in the user interface can be hid-

den or displayed in the View main menu. If you are in the report or helptext vie-

wer, select View > Input window  to return to the calculation module input 

dialog. 

In the Calculation main menu you can run the current calculation (see page  I-

81), add more calculations to the calculation module as default or special tabs and 

call subcalculations as dialogs. Select Calculation > Settings  to change 

the module-specific settings. 

In the Report  main menu you will find actions for generating and opening a re-

port. The system always generates a report for the current calculation. Click Re-

port > Drawing data to display Drawing data (on page  I-96) for the ele-

ment currently selected in the Report Viewer (see page  I-78). Select Report > 

Settings  to change the report's font size, page margins and scope. The actions 

for saving, sending and printing are only active if a report is open. 

You can open and close the Graphics window (see page  I-71) of a calculation mo-

dule in the Graphics main menu. Select Graphics > 3D export  to access 

KISSsoft's CAD interfaces. Select Graphics > Settings  to choose the CAD 

system into which you want to export the selected element. 

In the Extras  menu you will find the license tool, the configuration tool and the 

database tool. In this main menu you can start the Windows calculator and change 

the language (see page  I-49) and system of units (see page  I-50). In Extras > 

Settings  you can change general program settings such as the formats for time 

and date values. 

In accordance with Windows conventions, at the end of the menu bar you will find 

the Help  icon which you can use to navigate in the KISSsoft manual. In Help > 

About KISSsoft  you will find information on the program version and on the 

support provided by KISSsoft. 

In addition to the main menu, KISSsoft uses context menus in many locations. 

Context menus give you access to actions for a particular area or element of the 

software. Context menus are normally called up via the right-hand mouse button. 
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The Tool bar gives you faster access to actions from the menus that are used 

particularly frequently. You should also note the tool tips which display informati-

on about the actions in the Tool bar as well as other descriptions in the Status bar 

(see page  I-80). 

The Calculation , Report  and Graphics  main menus are only active if a 

calculation module is open. The actions available in these menus may vary 

depending on the current calculation module. 
 

NOTE 
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4.2 Docking window 
Beside the menu bar, Tool bar and Status bar, the docking windows are important 

elements in the KISSsoft user interface. Docking windows are windows that, can 

either be moved freely on the desktop, like a dialog, or can be docked onto the pa-

ges of the program, in any arrangement that suits you. Several docking windows 

can be placed on top of each other and be represented as tabs. 

You can unlock a docking window by double-clicking in its title bar. You move a 

docking window by clicking with the left-hand mouse button in the title bar and 

moving the mouse with the key held down. If you move the mouse close to the ed-

ge of the main window, a new position for the docking window will be displayed.  

Release the mouse button to position the docking window. Docking windows can 

be displayed and hidden via the View  menu. (see page  I-66) 
 

4.2.1 The module tree 
The module tree shows all KISSsoft calculation modules in an easy to understand 

and logically structured list. Any calculation modules for which you have not 

purchased a license are grayed out. You open a module by double-clicking on it 

with the left-hand mouse button. The current calculation module will be shown in 

bold. 
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Figure 4.2: KISSsoft calculation modules 

 
 

4.2.2 The project tree 
The project tree gives you an overview of the open projects, and the files belonging 

to these projects, and highlights the active working project (see page  I-90) in bold. 

You use the project management (see page  I-87) functions via the Project me-

nu or from a context menu (see page  I-66). 
 

4.2.3 The Results window 
The KISSsoft results window displays the results of the last calculation. 

 

Figure 4.3: The KISSsoft results window 

 
 

4.2.4 The Messages window 
The messages window displays all information messages, warnings and errors. Ge-

nerally, all additional messages are not only displayed, but also in a message box. 

You can change the way that information and warnings are displayed in a message 

box by selecting Extra s >  Settings , and clicking on the Messages tab. 
 

4.2.5 The info window 
The Info window displays information that is displayed when the user clicks on an 

Info (see page  I-83) button in the calculation module. You zoom and print the in-

formation via a context menu (see page  I-66). 
 
























































